Virtual Host Settings not saving

Discussion in 'Install/Configuration' started by cyberzen, Jan 19, 2005.

  1. mistwang

    mistwang LiteSpeed Staff

    The permission should be set properly not only for public_html, but also for all of its parent directories, the user that the web server running as should be able to access that directory.

    Your changes has been saved to the configuration file, but "public_html" is not accessible, error log shows that already.

    For the failed listener problem, please do "killall lshttpd" from command line to make sure all lshttpd process had stoped.
    check if any application using port "7080", do "netstat -an | grep 7080".
  2. mistwang

    mistwang LiteSpeed Staff

    You cannot and it is not the problem.
    The problem is that your firewall rule blocks connections to that address, so you can not apply changes from admin interface.

    Your changes made in the admin interface has been saved to configuration file, what you need is just a manual restart from command line.

    Then the permission of "/opt/lsws/zhentai/public_html/" is not set properly somewhere alone the path, so lshttpd can not access that directory, fix the permssion problem, then restart web server, you problem should be solved.

    Those two problems does not related to each other, you need to fix them one by one. :)
  3. cyberzen

    cyberzen Active Member

    Ok I turned off my firewall, and also chmod my entire home dir to 777, I reinstalled lsws to home dir under /home/lsws

    Basically what I do after install if, I copy the dir DEFAULT to whatever name my domain is like mydomain dir, then I acces web admin and I configure the paths.

    I was able to setup one listener, but the rest are not running, virtual hosts are up now tho. It just doesnt seem to be mapping correctly.

    Am I doing something wrong?

  4. cyberzen

    cyberzen Active Member

    Ok I found out whats wrong, even though I specified document root for one of my domains to be


    it's still pointing doc root to


    why? I've double checked my settings in the web admin and doc root is set to /home/mydomain/public_html
  5. cyberzen

    cyberzen Active Member

    Yay finally got one of my domains working! :) However my other listeners are still not working for my other domains :(

    Also I still don't understand why my doc root is still going to /home/lsws/zhentai/html

    basically to get it to work I just copied my html files over, so its just a stop gap fix, what i'd really want is to specify that my doc root goes to


    any suggestions?
  6. cyberzen

    cyberzen Active Member

    Another problem, is that I put in index.html,index.htm for the index files in general server settings, but when I enter i still cannot access the index.htm file.
  7. cyberzen

    cyberzen Active Member

    YAY finally managed to get everything to work!! Thanks for all your help dude.
  8. cyberzen

    cyberzen Active Member

    BTW found the answer for the index prob, I had to specify in the virtual host setting to use the server setting.
  9. mistwang

    mistwang LiteSpeed Staff

    Are those listeners started properly, is the listener to vhost mapping set properly? Please check the error log and make proper adjustment.

    Make sure permissions for /home and /home/zhentai are set properly in addition to public_html, if those files are owned by another user, then you should let nobody join the group of that user. You really need to read some document and have a good understanding of Unix security model. ;-)
  10. cyberzen

    cyberzen Active Member

    Its a dedicated server, plus I have 34wldsf;ksdf90 password heh
  11. cyberzen

    cyberzen Active Member

    BTW, there still seems to be a bug with the absolute path in Doc root, it's weird man. Is there any limit to how many virtual host one listener can handle? Right now I got 1 listener which maps all my domains, and only 4 domains are working.

    Doc root still wants to be in /home/lsws/mydomain/html instead of /home/mydomain/public_html

Share This Page