Virtual Hosts & Additonal Websites

Discussion in 'Install/Configuration' started by capbiker, May 26, 2008.

  1. capbiker

    capbiker Active Member

    I just recieved this email:-

    Should I forward that to the tech's here, and what is the actually core file called that it meants?
  2. mistwang

    mistwang LiteSpeed Staff

    3.3.13 release package is available now, just change the version number in the download link to get the new release package.
    Should be fixed.
  3. brrr

    brrr Well-Known Member

    I'm confused.

    From your lsof listing and other parts of your post, you seem to have access to two IP addresses: *.171, and *.172. Is that right?

    And are we talking about just running Litespeed here, with no Apache running anywhere, or running both side-by-side, but perhaps on different IP addresses?

    My experience is running Apache and Litespeed side by side on one server but serving up web sites off different IP addresses over port 80. That's the sort of setup I was thinking about when I made my config suggestion. Maybe it doesn't match what you want to do.
  4. capbiker

    capbiker Active Member

    I have downloaded 3.3.13 and upgraded it, and I am still getting the same error for *:80. I have restarted the server a number twice to make sure that the settings take. But still getting the same error. Looking at the logs it is showing the followings errors:-

    [config:server:listener:*:80] failed to start listener on address *:80!
    HttpServer::addListener(*:80) failed to create new listener
    HttpListener::start(): Can't listen at address *:80: Address already in use!

    Ok what I want to happen is to have litespeed as the main server (At the moment I don't have any need for apache to be running). But I am having major problems with Virtual Hosts because I am going to be hosting my main website (The main part of my server is working ok with that). But I am going to also be hosting my friend's website and also another smaller website of mine on it too.

    When I try to set up a sub account to host my friends website and upload everything for it. When I go to the correct address for where it is located nonthing comes up, it is just a blank screen. Looking at the actually source of the page it is showing a 403 error. So there is a problem with the virtual host somewhere or I have or else something else has been configured wrongly.

  5. ffeingol

    ffeingol Well-Known Member

    If it says port 80 is in use, use the lsof command to figure out what has port 80.

    You said you are using cPanel. Did you follow the LSWS/cPanel configuration and configure LSWS to just read the httpd.conf?

    Finally, did you just try shutting down LSWS and starting Apache back up? If the "new" domain does not work properly with Apache, it's prob. never going to work right with LSWS.
  6. capbiker

    capbiker Active Member

    I managed just fixed it. In the end, I decided to just rebuild the server from scratch and got rid of some of the problems that I had before.

    Still had a bit of a problem, was going to post in here for some more help with the LSWS not reading the httpd.conf. It wasn't until I read your reply and looked at the wiki config instructions and did what it said. That the website loaded propertly now. :)

    Still need to sort out some more stuff with the server, but it should not take me as long as it did the first time because I know what I am doing now.


Share This Page