Web Host Essential and LSCache

Discussion in 'General' started by snewtonge, Oct 4, 2018.

  1. snewtonge

    snewtonge Member

    I was using a LiteSpeed license and had LSCache as an addon, but I started using a new LiteSpeed license reseller and they started offering the new LiteSpeed licenses, so I purchased a Web Host Essential license and changed the license in WHM to the new Web Host Essential license, but now LSCache doesn't seem to be working.

    It was my understanding that the new licenses include LSCache or am I mistaken?

    From the LiteSpeed store, it says:

    "Included with every plan"
    "LSCache (LiteSpeed Cache) full-page caching module is included in all licenses".

    Any help would be appreciated!
     
  2. mistwang

    mistwang LiteSpeed Staff

    Please make sure upgrade to 5.3.1 .
    Yes, LSCache is included, maybe it is a problem with your cache setup?
     
  3. snewtonge

    snewtonge Member

    I'm using 5.3.1
    In the attached image, this is what I see in LiteSpeed.
    Any suggestions to try?
     

    Attached Files:

  4. Michael A

    Michael A Administrator Staff Member

    Hello @snewtonge,

    Can you click on the license status page and post what is reported? The WHM plugin my need to be tweaked if you are running into trouble on one of our new license types.

    Regards,
    -Michael
     
  5. snewtonge

    snewtonge Member

    Current License Status ( Serial: (REMOVED) )
    • Web Host Essential (1-Worker) license - Check against license server
    • 2018-10-04 22:26:07.044980 [NOTICE] Memory size is: 32560272KB.
    • [OK] Leased license key 1 will expire in 34 days!
     
  6. snewtonge

    snewtonge Member

    Just to note, initially all I did was use "Change License" and entered the new license and since then LSCache has stopped working.

    I've since tried uninstalling and reinstalling LSWS, but still the same.
     
  7. Michael A

    Michael A Administrator Staff Member

    Thanks for the information,

    If you don't mind, please private message me with your new serial number so that we can confirm that the issue is not somehow coming from our licensing server.

    Regards,
    -Michael
     
  8. snewtonge

    snewtonge Member

    I sent it to you.
     
  9. Michael A

    Michael A Administrator Staff Member

    Thanks, will let you know once we figure out what the problem is.
     
  10. Michael A

    Michael A Administrator Staff Member

    Hello again @snewtonge,

    I've confirmed this as a license type translation bug in the WHM plugin due to an edge case that was not handled properly. This caused the new license type to be displayed when it should not have been. Checking the licensing server, you are actually currently using one of our old license types (1-CPU) which does not include LSCache by default.

    The good news is that this can be easily fixed by either upgrading your current license to include LSCache or upgrading your license to one of our new license types which include LSCache by default (The "Web Host Essential" license would be the closest match to our old 1-CPU license).

    I appologize for any confusion that this may have caused. We should have this fixed in our next WHM plugin release (tbd).

    Regards,
    -Michael
     
  11. snewtonge

    snewtonge Member

    Ok, I'm confused then, because according to the reseller ([Link Removed]), the license is supposed to be the following:

    Product/Service:
    LiteSpeed Licenses - LSWS Web Host Essential

    So the license is not actually the above?
     
    Last edited by a moderator: Oct 4, 2018
  12. Michael A

    Michael A Administrator Staff Member

    Correct, I have sent you a private message regarding this as well.
     

Share This Page