WHM 11.40 and LiteSpeed plugin

Discussion in 'General' started by jacob, Nov 7, 2013.

  1. jacob

    jacob Member

    After update to cPanel/WHM 11.40 I get the following when trying to access the WHM LiteSpeed plugin:

    HTTP error 401


    WHM is configured to disallow execution of unregistered applications when logged in as root or a reseller with the "all" ACL. To enable this functionality you must do one of the following: Register this addon using /usr/local/cpanel/bin/register_appconfig (http://docs.cpanel.net/twiki/bin/view/SoftwareDevelopmentKit/AppConfig), Enable the "Allow apps that have not registered with AppConfig to be run when logged in as root or a reseller with the "all" ACL in WHM" option in "Tweak Settings", or add permit_unregistered_apps_as_root=1 to /var/cpanel/cpanel.config, and run /usr/local/cpanel/etc/init/startcpsrvd

    Will this be fixed in the upcoming WHM plugin?
  2. DoM

    DoM Well-Known Member

    I am waiting this fix too.

    Waiting for your reply

  3. mistwang

    mistwang LiteSpeed Staff

  4. webhostnix

    webhostnix Active Member

    Just :

    # nano /var/cpanel/cpanel.config
    add line = > permit_unregistered_apps_as_root=1

    and last


    I have tested it and worked
  5. mistwang

    mistwang LiteSpeed Staff

    Latest whm plugin does register itself, so there is no need to allow permit_unregistered_apps_as_root change is not required.

    4.2.5 comes with the latest whm plugin, should address this as well.
  6. DoM

    DoM Well-Known Member

    i reinstalled whm plugin overwriting old one but no way.

    cPanel still said that is an app not registered.

    I also update manually to 4.2.5 but same problem.

    Waiting for your reply

  7. Michael

    Michael Well-Known Member Staff Member

    Howdy all,

    Got the bug fixed. The new version of the WHM Plugin (2.1.1) addresses this. If you force reinstall LSWS 4.2.5 (from the WebAdmin console, or using lsup -f -v 4.2.5 , or from WHM) the new version of the plugin is included.

    If you allowed unregistered apps to run as root in your WHM settings, you can turn that off after you reinstall with the new plugin.

    Thank you for the bug report!

  8. WiredTree

    WiredTree New Member

    This solved the initial issue, but the error still shows up in the license frame.

  9. Michael

    Michael Well-Known Member Staff Member


    Reproduced. But, while that doesn't look good, it shouldn't affect functionality. You should still be able to click agree and manipulate licenses.

    We'll make sure that's fixed in the next release.


  10. Michael

    Michael Well-Known Member Staff Member


    Fixed in the new build (2.1.2). You can update with the following script:




Share This Page