Will there be official support for Rails >= 2.3

Discussion in 'Ruby/Rails' started by tdinkins, Jan 26, 2009.

  1. kule

    kule Member

    Oh just to add - remember that we're using a regular expression to find the version. If it can't find the constant we're after rails_ver will end up being nil (similar to null in most other languages).

    So you may want to check before using it:

    if rails_ver.nil?
      # assume old way or throw exception
      # whatever you wish to do
    Last edited: Mar 18, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    Now, the RailsRunner.rb in the latest 4.0 release package should be compatible with all Rails release now.
  3. pguy

    pguy Active Member

    Is there any documentation on getting Rails 2.3 to work with LS 4.0?
  4. mistwang

    mistwang LiteSpeed Staff

    Just replace the RailsRunner.rb with the one from LS 4.0. it should work with 3.3.24 release as well.

Share This Page