Wordpress wp-admin 503 The server is temporarily busy

Discussion in 'PHP' started by anything, May 28, 2011.

  1. anything

    anything Well-Known Member


    I've moved a bunch of wordpress sites from one litespeed server (v4.0.17) to a newly setup and much more powerful server (v4.1.1) and now anytime someone successfully logs into a wordpress sites (/wp-admin) they receive an error "503 Service Unavailable The server is temporarily busy, try again later!"
    The wordpress sites appear to work fine until someone successfully enters their username/pass in /wp-admin/.

    The errors reported in the error log are something along the lines of the following (I've tried to remove anything too specific)
    2011-05-29 03:33:35.785 [INFO] [] connection to [/tmp/lshttpd/APVH_www.sitename.com_Suphp.sock] on request #0, confirmed, 1, associated process: 21354, running: 0, error: Connection reset by peer!
    2011-05-29 03:33:36.051 [INFO] [] connection to [/tmp/lshttpd/APVH_www.sitename.com_Suphp.sock] on request #0, confirmed, 1, associated process: 21358, running: 1, error: Connection reset by peer!
    2011-05-29 03:33:36.052 [NOTICE] [] Max retries has been reached, 503!
    2011-05-29 03:33:36.052 [NOTICE] [] oops! 503 Service Unavailable
    2011-05-29 03:33:36.052 [NOTICE] [] Content len: 0, Request line: 'GET /wp-admin/ HTTP/1.1'
    2011-05-29 03:33:36.052 [INFO] [] Cookie len: 441, wordpress_9216fec0724......bdace4fa=andrew%7C1306775590%.......aff92b5d4008c6; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_9216fec0724fd8......ebdace4fa=andrew%7C130677559......26c60df843d3; __utmz=151998636.1306603282.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); __utma=151998636.1131235342.1306603282.1306603282.1306603282.1; __utmc=151998636; __utmb=151998636.13.10.1306603282
    /usr/local/lsws/logs/stderr.log reports no errors

    As this site was working on the old server I suspected the newer php version was the cause of the problem.
    But I have tried recompiling and using php to be 5.3.6, 5.2.17 and 5.2.14 (same as the old server) without any success.
    5.2.17 was the worst, at random points random php scripts would terminate early.

    I compared the results of phpinfo() between the old and new servers, and noticed the only difference was "Server API LiteSpeed V5.4" vs "Server API LiteSpeed V5.5". So I literally copied /usr/local/lsws/lsphp5/ /usr/local/lsws/fcgi-bin/ and the php config from the older working server to the new server. phpinfo() now reports 5.2.14 with API 5.4, but wp-admin is still not working and reports the same error.

    APC is installed, but has been disabled for all my tests.

    In my searches on the forums here I've seen several posts for the same problem but no solutions except for things like "i recompiled php and it fixed itself".

    I'm lost as to where to go from here.
    Any ideas?

  2. anything

    anything Well-Known Member

    I've managed to find out that its the curl module.

    my os has an updated libcurl library (7.21.6), and there must be something going wrong with it inside lsphp, because as soon as curl_exec is used anywhere in a script it suddenly stops working.
    running php on command line works fine.

    i rolled back to 7.21.0 with no success, and after -LOTS- of stuffing around i managed to get libcurl 7.15.5 installed, and finally got php compiled against the old version instead of the current (i wanted 7.19.7 to match my old server, but couldnt argue php it into using it).
    suddenly everything seems to be working properly now.

    suggest that some new stuff in curl is causing problems with something to do with LSAPI. i experimented with trying to catch stderr from my lsphp processes, but never seemed to catch anything.

    hopefully you can look into it.
    Last edited: May 28, 2011
  3. webizen

    webizen Well-Known Member

    what is your server environment such as OS version, 32-bit or 64-bit?
  4. anything

    anything Well-Known Member

    Fedora14 64bit
    lsws enterprise 2cpu
  5. webizen

    webizen Well-Known Member

    are you using any control panel like cpanel, etc?
  6. anything

    anything Well-Known Member

    hi webizen

    no control panel.
    we're using apache config tho.

    having problems replicating the issue?
  7. fastproxy

    fastproxy Well-Known Member

    I have had similar issue with Wordpress login and show error 503. Some error i found on message log:

    I fixed this by recompile PHP 5.3.10.

    my OS: CentOs 5.6 64bits with direct admin

Share This Page