XenForo bug with Litespeed

Discussion in 'Bug Reports' started by cmeinck, Jun 14, 2013.

  1. cmeinck

    cmeinck New Member

    There is an ongoing thread at XenForo (forum software) where folks seem to have isolated an issue between Litespeed and Xenforo that causes CSS to break, not rendering the page correctly. Apparently, there is a fix that will be rolled into a new update. I wanted to check on the status of this update and if I could get early access to the fix. I am a customer of WiredTree, so would need to pass any relevant information to them on how to upgrade and apply the fix.

    As you can imagine, customers who cannot access pages in a forum are likely to leave. I'd like to get this corrected as soon as possible and look forward to your assistance.

  2. NiteWave

    NiteWave Administrator

  3. cmeinck

    cmeinck New Member

    You can reproduce on my site. Also, there are a number of XenForo owners who have the exact same problem. Apparently, a fix has been supplied by Litespeed to a host. How can others have access to this fix? Waiting for a new update doesn't seem like a plausible solution, given the state of our sites, which are not functioning correctly.
  4. NiteWave

    NiteWave Administrator

    what's your site's URL ? you can PM it.

    I've managed to search out the conversation with Mike you mentioned in your reference. He emailed us around June 1, about this "304 response issues". We just replied it might be a php issue and asked him to try on apache ? then no response from him since then. As far as I know, we don't insist on this is a php issue, and haven't ever said will fix it in next release. To us, it's just an issue need more information, but lost the further response from the customer. This is why I ask you to provide an URL to investigate it further. Once we confirm the issue, we'd glad to fix it.
  5. Foxy11

    Foxy11 New Member

    I'm experiencing this issue, it would appear it's giving a 304 response with the content type: text/html and causing Google Chrome to ignore the css.

    If I switch to Apache, the content type is reported as text/css and loads perfectly.
  6. NiteWave

    NiteWave Administrator

    I checked the site http://canyoncollective.com/ just now, it's running litespeed.

    the css is combined to serve through php, in example of homepage:
    no single .css static file seen under chrome's devtool->Network -- this means no .css file served by litespeed directly.

    if css is served via css.php, then its response headers are set by css.php, include 304 status, content-type, litespeed just bypass them.

    in your case, css is served by css.php or litespeed ?
  7. Foxy11

    Foxy11 New Member

    It would appear that the majority of the css is served by css.php.
  8. NiteWave

    NiteWave Administrator

    can you PM your site's URL ?
    and ideally can provide the steps to reproduce the issue.
  9. NiteWave

    NiteWave Administrator


    from Foxy11:
    but I still can't reproduce the issue on his site, the issue is that: in chrome, sometimes, /css.php will show 304 http status but with content-type "text/html"

    the simplest test case is just copy css.php to test.php, then refresh /test.php many times, but always show 200 status when test from my chrome.

    the issue still not clear. expecting more info and tests on it.
  10. PSS

    PSS Well-Known Member

    Just a guess:

    Does the css.php always send

    header("Cache-Control: private");
    header("Content-Type: text/css");

    ... maybe there is some bug which prevents those headers sent (something printed before they are sent)? I could be that Apache makes it css MIME automatically when there is no content type set?
  11. Cory

    Cory Member


    I'm also experiencing this issue and from what I've read over in the forums this patch needs to be released and a lot people are having issues and canceling/switching to something that works solution, Like Apache or Nginx. Honestly, don't want to go that route at this point and this issue seems very serious and needs to be addressed immediately.

  12. NiteWave

    NiteWave Administrator

    don't think there is any patch from lsws side so far ...
    refer to previous post, you can see there is a php "patch" --- please read
    you can try it and confirm it quickly.
  13. Cory

    Cory Member

    Yeah that doesn't work, Already said and confirmed by many people.
  14. NiteWave

    NiteWave Administrator

    for this issue, we have had no chance to identify it / reproduce it at our end.

    just from this thread, people can see that it looks many complaints about this issue. we're also willing to identify the issue ASAP but unfortunately, no chance to investigate this issue further. to proceed, you can PM me your site's URL and steps to reproduce the issue or provide us the root access. may be able to identify the issue quickly.
  15. MikeF

    MikeF Member

    Every single user of XenForo has experienced this issue with LiteSpeed. The license for Litespeed and the upgrades can cost upwards of thousands of dollars. Do you have any inclination to try to resolve the bug, since it does not occur in Apache or nginx whatsoever? Clearly, XenForo tried to push the headers you suggested but that does not solve the problem. The CSS cuts out on the page because it is never sent (possibly being sent as a different mime type or not at all). It is amazing to me that you are charging your customers big money but can't set up a XenForo board and debug this issue.
  16. NiteWave

    NiteWave Administrator

    there is a good news for this issue, but need end user's verification.

    in recent 2 weeks, we got a similar report which only have issue on chrome.

    in the end, we're able to reproduce this issue on user's website and have a fix for it quickly. the most time is spent on reproducing the issue.

    please force re-install the latest 4.2.4. should fix the issue.

    and thanks for the discussion in this thread. so when the user reported us the issue, I immediately realized that it maybe the same issue discussed in this thread for a long time but no result yet.
  17. MikeF

    MikeF Member

    It is still happening.

    Attached Files:

    • ex1.jpg
      File size:
      27.3 KB
  18. NiteWave

    NiteWave Administrator

    like I stated before, once we can reproduce the issue, should be able to fix it quickly.

    even we have a copy of XenForo, can't guarantee we can easily reproduce the issue. for the recent example, the issue comes with the open source opencart. but finally, I found that issue only happen when using a commercial theme -- the default theme (which is open source) never happen. opencart + rgen-opencart theme(commercial) + css-javascript-minifier vqmod(commercial) + enable css minify(need admin access) + chrome only, can reproduce the issue.

    the screenshot you provided, I can't read the URL, just know the issue still exist. which not helpful to resolve the issue. can you PM the URL so that I can easily reproduce it in my chrome?
  19. MikeF

    MikeF Member

    Unfortunately, this is not due to a custom theme, as it seems to occur with all themes, including the default. This is a live site and I cannot keep switching back and forth from apache to Litespeed with these rendering issues without losing valuable viewers and members. You will need to test it on another site that runs Litespeed with XenForo. As for it being limited to Chrome, this appears to happen at the sever level, and I'm not certain that is the case.
  20. mistwang

    mistwang LiteSpeed Staff

    You can configure LiteSpeed to run another port with port offset, like 2000, Apache is on port 80, LiteSpeed is on port 2080.
    So, we can trouble shoot this issue without affecting other users.
    Please send us the URL having this problem, it may not be required, but, a temp root access could get it resolve quickly if you do not mind.

Share This Page