[solved] PHP 5.5.6 Install Fails on APC

Discussion in 'Install/Configuration' started by ShannonA, Dec 10, 2013.

  1. ShannonA

    ShannonA Member

    I've been trying to upgrade to PHP 5.5.6 from 5.3.6 using the built-in PHP install.

    I'm using this flags:
    With PHP Mail Header Patch, APC, and pecl/memcache also checked.

    I get through the main PHP build, then I get these errors on the APC build:
    Any ideas?

    Thanks!
    Last edited by a moderator: Dec 14, 2013
  2. NiteWave

    NiteWave Administrator

  3. ShannonA

    ShannonA Member

    Yep, looks like that might be the case. Sigh. (And thanks for looking into it.)

    My prime concerns are security and efficiency because we have a large site with heavily used PHP scripts (vBulletin mostly). Any suggestions for best way forward? Stay with 5.3.X? Go with 5.5.X with some other add-on for PHP caching?
  4. NiteWave

    NiteWave Administrator

  5. ShannonA

    ShannonA Member

    So I tried recompiling with XCache, just checking the handy little "XCache" plug-in button and now when I called up phpinfo for my brand-new PHP 5.5.6 it doesn't show up.

    Did I miss something else that needs to be done to install XCache? Or is it visible in some other way?

    Thanks.
  6. NiteWave

    NiteWave Administrator

    please check if
    extension=xcache.so
    in php.ini

    to be compatible with php 5.5, cache 3.1.0 is required per xcache website.

    just now I tried lastest lsws 4.2.6 and complied lsphp-5.5.6 + xcache 3.1.0 successfully. xcache version is 3.1.0 when check "XCache"

    you can try on command line
    /usr/local/lsws/fcgi-bin/lsphp-5.5.6 -i
    see if any abnormal.
  7. ShannonA

    ShannonA Member

    Duh. Of course. Thanks; that was of course it.
  8. NiteWave

    NiteWave Administrator

    still problem? how about command line
    #/usr/local/lsws/fcgi-bin/lsphp-5.5.6 -i |grep -i xcache
  9. ShannonA

    ShannonA Member

    No problems. Just needed to be included as you said.

    I'm having some concerns about the performance of 5.5 with XCache vs. 5.3 with APC, but that's a whole 'nother issue.
  10. eva2000

    eva2000 Member

    You need newer APC version than 3.1.9. For PHP 5.3 and 5.4 I use APC 3.1.13 works fine for me. For PHP 5.5 APC 3.1.15-dev is only version that works for me with PHP 5.5.x. Unfortunately APC SVN trunk seems to no longer exist. But I have a saved copy I use of APC 3.1.15-dev renamed as APC 3.1.13 tarball.

Share This Page