4.0 RC1 release

Discussion in 'Bug Reports' started by mistwang, Feb 3, 2009.

  1. mistwang

    mistwang LiteSpeed Staff

    Cache function is only available for Enterprise 2-CPU and above.
  2. mistwang

    mistwang LiteSpeed Staff

    Large file support was not enabled for standard edition, if you use standard, please download the package again. it should be enabled now, lscgid problem should be fixed as well.
  3. justme

    justme Well-Known Member

    Yes, both issues are fixed, thanks a lot.
  4. Invictus

    Invictus Member

    Is this true?
    So, if I am using VPS license key, the cache function will not available?

  5. alexr

    alexr Member

    I found what I believe to be a new bug. My server had webmin, and when I tried to load the apache config the litespeed server would never restart. I would click restart and it would never come back up, I would have to restore the old settings then do a manual restart. When I downgraded back down to 3.3.24 it worked fine.

  6. kc8yds

    kc8yds Active Member

    i've been running this on my 3 servers now for a week -- no problems at all

    great job! :)
  7. Invictus

    Invictus Member

    There is no squid cache option for vps licenses.
    I have several vps and already using ls.
    Overall performance without squid cache option beaten up with pure nginx.
  8. anewday

    anewday Moderator

    So you are saying nginx beat up 3.3 too?
  9. mistwang

    mistwang LiteSpeed Staff

    Please send more information to bug (AT) litespeed ... ,
    we need a copy of the httpd.conf and all configuration files included to reproduce the problem in our lab.
  10. TomBG

    TomBG Active Member

  11. alexr

    alexr Member

  12. Invictus

    Invictus Member

    Otherwise, LiteSpeed has many advantages.
    1. htaccess
    2. Easy management and monitoring
    3. Best DDOS protection
  13. sip

    sip Member

    Following Custom Error pages which work on Apache doesn't work on V4.xRC:

    ErrorDocument 400 /error.php?400
    ErrorDocument 401 /error.php?401
    ErrorDocument 403 /error.php?403
    ErrorDocument 404 /error.php?404
    ErrorDocument 500 /error.php?500

    This is e107 cms.
    Would such pages not work?

  14. mistwang

    mistwang LiteSpeed Staff

    That's because the query string in the target URL, we will make it work in 4.0 release.
  15. mistwang

    mistwang LiteSpeed Staff

    Seems the query string part has been handled properly in LSWS already, Please give us more detailed description about the problem.
  16. sip

    sip Member

    Server is running 4.0 RC1.
    PHP is running in suexec mode.
    The custom error pages are setup in .htaccess
    script running is e107
    The error page is not showing up like it does on apache.
    I have sent you PM on this showing details

  17. MindTooth

    MindTooth Active Member

    Just got this message:
    cp: cannot stat `/home/mtuser01/sources/lsws-4.0rc1/lib/apc.so.*': No such file or directory
    chown: cannot access `/usr/local/lsws/lib/apc.so.*': No such file or directory
    chmod: cannot access `/usr/local/lsws/lib/apc.so.*': No such file or directory
    What can cause this? It seems that the package is missing some files.

    Birger :)

    Ed1t: Also the 404 page in the testpage isn't working.
    Last edited: Mar 2, 2009
  18. anewday

    anewday Moderator

    Any idea when 4.0 stable will be ready? Looking forward to the new benchmarks. Also, would like to see a list of bugfixes since the RC release.
  19. robfrew

    robfrew Well-Known Member

    Ever since upgrading to this new release, I've noticed that all of the pages on every site have a weird issue. What ever image is last to load, it takes about 1 to 2 seconds before it actually loads. In its place is the normal image place holder that the browser shows until it actually loads. At the bottom of the browser, it says 'Transferring data from www.websitename.com' which tells me it's waiting for the server to serve the last image.

    This has never happened before and is on every page no matter if it's just an html page or php page. What could be causing this? Is it a bug? We haven't changed anything to the configuration of the server or the litespeed except upgrading it to the latest RC1.

    ******** This ended up being a new router issue on our end. ****************
    Last edited: Mar 10, 2009
  20. mistwang

    mistwang LiteSpeed Staff

    that's interesting, please PM me more information about this issue, we need to verify and investigate.

Share This Page