4.1 > 4.1.1 upgrade - odd behaviour

Discussion in 'Bug Reports' started by XN-Matt, Jun 15, 2011.

  1. XN-Matt

    XN-Matt Well-Known Member

    We have some sites that call on files in other users directories, mainly for our multisite CMS.

    We do have open_basedir protection on and there are exceptions in place. This has worked flawlessly for years for all previous 4.x releases.

    We've just tried to upgrade to 4.1.1 on two different servers and the same behaviour is seen.

    The sites cannot see the files in other user directories. Permissions are correct, open_basedir still set correct too.

    If we switch back to 4.1, everything works as normal. Switching back to 4.1.1, it breaks again.

    When we enable errors, PHP can't seem to find the files, but they're there and work OK in 4.1 - and we're using the same PHP version too (i.e not recompiled that).

    Has something changed in the workings of LiteSpeed to perhaps, chroot them to their own directories that isn't in the changelog?

  2. NiteWave

    NiteWave Administrator

    maybe relate to symbol link ... can you change "allow symbol links" etc and see if 4.1.1 works fine.
  3. XN-Matt

    XN-Matt Well-Known Member

    I'll give it a try but none of the paths are symbolic.

    Edit, settings are already.

    Follow Symbolic Link Yes
    Check Symbolic Link No

    Last edited: Jun 15, 2011
  4. DraCoola

    DraCoola Well-Known Member

    And 4.1.1 doesn't have "Server Snapshot" anymore in it's panel Home
    Last edited: Jun 15, 2011
  5. mistwang

    mistwang LiteSpeed Staff

    Yes, it is removed from the home page to improve performance.
    Just use the status page.
  6. XN-Matt

    XN-Matt Well-Known Member

    How about a reply to the initial issue reported?

    We cannot use the new release.
  7. webizen

    webizen Well-Known Member

    try force reinstall 4.1.1 and see the issue remains.

    please also be more specific about the issue and provide some examples to help us duplicate the issue.
  8. XN-Matt

    XN-Matt Well-Known Member

    This has already been done and already confirmed NOT working on two servers.

    "We've just tried to upgrade to 4.1.1 on two different servers and the same behaviour is seen."

    I've explained the issue the best possible and there is no more information I can give you.
  9. webizen

    webizen Well-Known Member

    I am referring to the issue you reported below. Can you be more specific about it?

  10. XN-Matt

    XN-Matt Well-Known Member

    Not really.

    After upgrade, we get a PHP error stating the file not found, although it exists.

    If we switch back to 4.1 it is fine, with no error.

    I.e a script in /home/user1/public_html/ is trying to access a file in /home/user2/public_html/ - works in 4.1, but not in 4.1.1.

    Permissions are correct and user is allowed.

    Looks like some chroot is being enforced, even though it never has had a problem before.

  11. webizen

    webizen Well-Known Member

    please post a snippet of code in question.
  12. XN-Matt

    XN-Matt Well-Known Member

    Just any basic php include will show this problem.

    The php then errors stating the file cannot be found, when it does exist.
  13. cmanns

    cmanns Well-Known Member

    Strace php processes while a friend or ab hits a php page

    We went 4.0->4.1RC's->4.1 final ->4.1.1 yesterday it's been stable besides it randomly quits I think from the .rtstatus output but no php issues, and our clients sites have dozens and dozens of includes in sub directories and what not :)
  14. XN-Matt

    XN-Matt Well-Known Member

    I'd say largely impossible to do due to the amount of traffic that hits these boxes.

    Even the fraction of downtime we had when trying to work out what was going was too much.

    Either way, clear problem with 4.1.1 that didn't exist with any version prior (and we've been running for quite a few years now).

  15. cmanns

    cmanns Well-Known Member

    I've used it for over a year, maybe two but on and off till a year ago.

    As said I've ran all the 4.1 RC's in production env, doing about 30million hits a day or more.

    and I just switched to 4.1.1 - as people suggest do a force reinstall. You can just run litespeed on port 8080 or whatever fancy's you and test yourself instead of killing your traffic. Honestly though if that hurts you enough I'd look into HA and multiple web frontends.
  16. XN-Matt

    XN-Matt Well-Known Member

    Ditto, but that does not mean a version won't have a problem.

    If you read the post, you will see a forced re-install has been tried and DOES NOT work.

    HA, or DR isn't required for the platform is it is and these suggestions do not deal with the problem in hand which has been confirmed on multiple boxes, different base OS's, some integrated in cPanel, some not - hence the posting of the problem.
  17. webizen

    webizen Well-Known Member

    Could not duplicate the issue. sample code snippet is as follows:
    include '../../test1/public_html/test1.php';
    open_basedir is empty.
  18. cmanns

    cmanns Well-Known Member


    Doesn't seem like you've done any digging into the issue. I looked into my 4.1.1 install, what open_basedir settings do you use?

    I'll test this on a few CentOS5 systems with 4.1.1
  19. XN-Matt

    XN-Matt Well-Known Member

    By default it is on, with exceptions. Have turned completely off also with no difference in the outcome.

    Have recompiled PHP against 4.1.1 if that made any difference. None. Have tried force re-install again, nope.

    4.1 works flawlessly, but would rather remain current.

    @webizen: instead of just saying you can't find a problem, It would be ideal if someone actually could contact us to look in to this because the software is not working, and after all, it is paid for software that we'd expect you to actually help with.
  20. webizen

    webizen Well-Known Member

    pm your server temporary root access so we can look into this further.


Share This Page