Issues after switching back to Apache

Discussion in 'Bug Reports' started by Cyberfyber, Feb 6, 2018.

  1. Cyberfyber

    Cyberfyber Member

    Hi, couldn't think of a better thread group to post this in...not that I'm inferring Litespeed is the culprit.
    Been using Litespeed since early-mid 2017 I believe and have done well.
    BUT, been testing things by switching to Apache and I end up not being able to get back into my WP Admin and my site's a screwy mess with messed up styling and worse. Eventually, some pages will end up with
    Error establishing a database connection
    Of course turning LS back on sets the world right again.
    What I'm being told by my host is that
    ""it appears, the MySQL server is having issues keeping up with the amount of connections you're receiving at once.
    Your initial PHP processes are using a lot of memory, coupled with all of the MySQL calls for each connection, which is killing services and causing reading of MySQL tables to stop short, hence the problems with the pages loading incompletely. ""

    My question is, does any of this even sound familiar in any way? I barely get any visitors this time of year and the problem with turning off LS occurs even after deactivating all my plugins.

    Any and all suggestions and direction would greatly be appreciated.
     
  2. Tishu

    Tishu Well-Known Member

    Hello,
    You need to optimize your page. First check what provokes so many mysql connections and reduce them. You can test to change the theme/template too.
     
  3. Cyberfyber

    Cyberfyber Member

    Hello Tishu,
    Went about it all again this afternoon. Changed the theme on a separate install of the same domain and had a look at a separate domain I own under the same server setup. All screwed up. The second domain wouldn't even let me see the pages. Ended up with the following:
    I'm not looking to put down Litespeed, but I feel as if I'm a prisoner of it now.

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
     
  4. Tishu

    Tishu Well-Known Member

    Hello again,
    After switch to apache check the logs files for that error. Error 500 in most cases is related to php or try to remove temp htaccess file and test.
     
  5. Cyberfyber

    Cyberfyber Member

    Thanks for the suggestions Tishu.
    In a simpler display...I created numerous dummy WP installations on yet another separate domain within the same server. Brand new install(s).
    I get the 500 errors if I've got the following in my htaccess file AFTER switching off Litespeed.

    Code:
    php_value max_input_vars 5000
    php_value max_execution_time 600
    php_value post_max_size 50M
    php_value upload_max_filesize 64M
    What might that tell me?

    Mind you, unfortunately, it's not so simple with my big Main site.
     
    Last edited by a moderator: Feb 8, 2018
  6. Tishu

    Tishu Well-Known Member

    Your apache conf is working with suphp probably. You may have to move this php settings to main php.ini file or in custom user php.ini.
     
  7. Cyberfyber

    Cyberfyber Member

    Thanks Tishu. Couldn't find any options to do so in MultiPHP Manager so I had my host do it for me.
    That fixes things in my subdomain and other domain installs. BUT not with my big one.
    So Tishu, you suppose this is ALL just a matter of the junk I've got in my htaccess file in the Big site?
    Have got stuff in there from 'Wordfence', My Cache plugin and 'Really Simple SSL'
    'and I've got a main htaccess at the root and one within the subfolder install of WP.
     
  8. Tishu

    Tishu Well-Known Member

    Can you send me the content of that htaccess on PM.
     
  9. Cyberfyber

    Cyberfyber Member

    Thank you Tishu for the guidance. Things are back on course this morning after trying your suggestions. But will have to finish the job little by little until I'm sure I'm in the clear. Thanks again! :)
     
  10. Tishu

    Tishu Well-Known Member

    I`m glad that this was resolve ;)
     

Share This Page