[Resolved] Magento/CPANEL/LiteSpeed issue

Discussion in 'Install/Configuration' started by Geoff, Mar 25, 2010.

  1. mistwang

    mistwang LiteSpeed Staff

    have to rename /usr/local/apache/conf/userdata/std/2/pcshop/cp_php_magic_include_path.conf

    to avoid

    php_admin_value include_path ...

    being set, once set, the magento php code cannot change include path, thus cause the error.
    In our cPanel setup, there is no "userdata" directory at all, so it must be something special for your cPanel setup.
  2. Geoff

    Geoff Active Member

    This is default setup, but I solved the problem now:

    I had enabled php magic for something (cant recall why now), but it was non essential. Turned it off and renamed the file back, restarted LS, and its still working, so all good. Thanks heaps for your help Mistwang (and nite too).
    So far so good.

    The default magento site would take 1-3 secs to fully render on my screen, with litespeed there is virtually no lag at all. Wicked.
  3. NiteWave

    NiteWave Administrator

    Thanks for the sharing.
  4. Geoff

    Geoff Active Member

    my pleasure :)

    You can log out of the server now though ;)
  5. Jamesc

    Jamesc New Member


    I'm installing magento- in the server with litespeed+cpanel. On first take of admin page, I get 503 error page.

    503 Service Unavailable

    The server is temporarily busy, try again later!
    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    I am getting strange entires in error logs.

    2010-05-04 00:42:52.059 [INFO] [] connection to [/tmp/lshttpd/APVH_dtech.net_Suphp.sock.802] on request #0, confirmed, 1, associated process: 24829, running: 0, error: Connection reset by peer!
    2010-05-04 00:42:52.059 [NOTICE] [] Max retries has been reached, 503!
    2010-05-04 00:42:52.059 [NOTICE] [] oops! 503 Service Unavailable

    I tried to raising "Max Request Body Size". But still no luck.

    Anyone please advise.
  6. NiteWave

    NiteWave Administrator

    1. is it working under apache?

    2. if it is, have you done "Build Matching PHP Binary" in Litespeed Web Server" plugin, without error?

    3.if 2 is ok, run phpinfo(), ensure lsphp has built correctly.

    in a trouble shooting a few days back, a wordpress site return 503 error. lsphp is latest 5.2.13 with
    eAccelerator v0.9.6
    ionCube PHP Loader v3.3.14
    Zend Optimizer v3.3.9

    in the end, I disabled its suhosin module and working fine.

Share This Page