[solved] Error 404 - Page not found

Discussion in 'Install/Configuration' started by DatNguyen, Apr 19, 2018.

  1. DatNguyen

    DatNguyen Member

    Sorry for my english.

    I'm a newbie to LitespeedWebserver. I have just installed my fresh wordpress webiste on LSWS. Homepage display very well. But when I navigate to another links in this my webiste, LSWS display error: "404 page not found". I realize that in Wordpress Dashboard 'Permalink' settings, if I choose 'Plain' setting, LSWS work fine. But if I choose an another, error will occur.

    Thanks in advance for helping me.
     
  2. NiteWave

    NiteWave Administrator

    looks like .htaccess is missed. can you check if document-root/.htaccess exist.
     
  3. DatNguyen

    DatNguyen Member

    Thanks for reply.

    Yeah, .htaccess file exist in my 'html' folder. This is .htaccess content:
    Code:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    
        RewriteEngine On
        RewriteBase /
        RewriteRule ^/index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /index.php [L]
    
    </IfModule>
    # END WordPress
     
    Last edited by a moderator: Apr 19, 2018
  4. Tishu

    Tishu Well-Known Member

    Hello,

    Is this Litespeed webserver enterprise or OpenLiteSpeed?
     
  5. DatNguyen

    DatNguyen Member

    This is Litespeed webserver enterprise with trial key
     
  6. Tishu

    Tishu Well-Known Member

    Hello again,

    So first check the log files for more information. In the htaccess i can see "RewriteRule ^/index\.php$ - [L]". The default line is "RewriteRule ^index\.php$ - [L]".
     
  7. DatNguyen

    DatNguyen Member

    Thanks. I have edited .htaccess, but nothing changed.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]​
    </IfModule>
    # END WordPress
     
  8. NiteWave

    NiteWave Administrator

    is virtual host from apache's httpd.conf or created in litespeed web admin(i.e.,native virtual host) ?
    if it's latter one, please show web admin->virtual hosts-> General-> HT Access
     
  9. DatNguyen

    DatNguyen Member

    Thanks for reply.

    HT Access is default settings:
    • Allow Override: None
    • Access File Name:
    It seem I haven't configured correctly. How do I do that?
     
  10. NiteWave

    NiteWave Administrator

    • Allow Override: check all except "None"
    • Access File Name:.htaccess
     
    DatNguyen likes this.
  11. DatNguyen

    DatNguyen Member

    I solved this.
    Again, Thanks you so much.
     
    NiteWave likes this.

Share This Page