[Solved] CSS combine breaking cart page even after excluding all CSS files


My website has a funny behaviour, If I set CSS combine ON, the woocommerce cart page breaks, trying to follow the instructions on how to fix problem caused by the optimization, I made a list of CSS files and I added them all to the CSS excludes field and I still get the problem.

So even if I exclude all the CSS files still get the problem with the cart page (thats the only problem when I optimize CSS)

I compared the files without CSS combine and with CSS combine and all CSS files exclude and I get the same amount of files

Any idea what I am doing wrong?


Staff member
Hi @pixelar,

Can you check if combine works by browser developer tool -> Network -> CSS. If css files number is same as no combine which means combine is not working, then why it causing the woo cart page breaks? Could you provide a screenshot?

Also a screenshot for exclude, thanks.

If you don't want to provide screenshot of setting in forum, please provide the report number by clicking the send report inside of the cache plugin.

here is a screenshot of the cart working https://cl.ly/5629423cc9d3 (no combine css)
here is with combine on https://cl.ly/758fa9821fbd
I am not sure if I got your question, but here is the screenshot of that page with combine ON (no css files excluded) https://cl.ly/1cdf89fd416b
here is the screenshot with combine ON all css excluded https://cl.ly/31b8884750b4
here the files excluded https://cl.ly/3ae9a9df189e
Last edited by a moderator:


Staff member
Hi @pixelar ,

If exclude all success, you probably won't see random string .css in this screenshot https://cl.ly/31b8884750b4, right?
So I guess some css file you missed to exclude.

If you still can't find it, submit a ticket to LiteSpeed with wp access and allow us to check it for you. Better on a dev site if this production site is critical.

Last edited by a moderator:
Yes I prefer to give you access to a copy of the site were you can test and change whatever you want, I created a ticket, thank you for the support
Well to anybody that is using Astra theme and had the same problem, just add astra on the CSS excluded field, and that will fix the problem
Yes just add astra nothing else.
Last edited by a moderator: