problem with setting of cgi umask

my problem is when i want to set the umask setting of cgi under security tab in admin panel of litespeed.
i need to set it as 0022 but it just accept a value in range of 000-777 so i tried 002 as said in the forums posts but when i check the result of "echo exec('umask');" by php, it doesn't show the 0022 and also doesn't create files with 644 perm.
so i had tried so many values like 022 and 644 but it doesn't work....also i upgrade the webserver to 5.4 latest version but it doesn't work,yet.
after this, i edit the umask value by "nano" from ssh and set it on 018 and save and restart the webserver, now, it work very good and return 0022 on php and very thing ok but just when i want to set this value with admin panel of litespeed, the panel says: "this value is not valid for cgi umask"....
so what is wrong?!
also the litespeed does not print invalid value error on debug log for 018 but the portal says this value is invalid!!
is that really invalid? or this is a admin panel bug?
ok, thanks so according to octal nums to decimal nums conversion, i got that 018 is equal 0022 so to get 0022 on script side like php, i must set 018 for umask setting of cgi under security section manually on httpd_config.xml also for any external applications section on that config file? am i right?


LiteSpeed Staff
5.4.1 build 4 will be able to use 022 and parse it as octal numbers.
you can try the debug build now.
/usr/local/lsws/admin/misc/ -d -f -v 5.4.1
thank you i'm looking for it to update my servers.
i have some(about 4) servers that can not upgrade them at all, they are using 5.0.9 and some 5.1.9, so can i set umask by httpd_config.xml? is it safe?


Staff member
It has released and you can upgrade by:
/usr/local/lsws/admin/misc/ -f -v 5.4.1

There is no release log for each build but you can join LiteSpeed edge group to receive new build notice.