When I enable LiteSpeed, google console shows an error

Discussion in 'General' started by cabbola, Sep 28, 2018.

  1. cabbola

    cabbola Member

    When I enable LiteSpeed, google console shows an error:
    Code:
    - 3 (index):1 GET https://www.mywebsite.com/products/webfonts/fa-solid-900.woff2 net::ERR_ABORTED 404
    The cache files show an incorrect URL for these files. If I disable the cache the problem goes away. Or if I delete the cache the problem goes away until I refresh the page and the error comes back.
    Can anyone help with this, please?
    Cabbola
     
    Last edited by a moderator: Sep 28, 2018
    Scarlet Jonathon likes this.
  2. Pong

    Pong Well-Known Member Staff Member

    When you say "enable LiteSpeed", do you mean enable LiteSpeed cache plugin for WordPress? or something else?
    we may need your real URL to check.
     
  3. cabbola

    cabbola Member

    Sorry for not explaining more clearly, I do mean the LiteSpeed plugin. We have been using it for a while and have had no problems. Then we noticed that the website was slow to respond. I checked Google console and saw the errors. I disabled the LiteSpeed plugin and the problem persisted. I checked the cache files and within them were references to various font awesome files including fa-solid-900.woff2 which point to the wrong URL. I deactivated the plugin on the plugin page and the problem goes away. I have tried to see where these cache references come from but have run out of possibilities. I was hoping you could take a look and point me in the right direction. Thank you in anticipation.
    Cabbola
     
  4. cabbola

    cabbola Member

    URL: www.buyatestkit.com. Currently, cache is disabled so the site runs better.
     
    Last edited by a moderator: Oct 1, 2018
  5. Pong

    Pong Well-Known Member Staff Member

    Your fa-solid-900.woff2 seems from a remote site instead of the same server: https://use.fontawesome.com/releases/v5.3.1/webfonts/fa-solid-900.woff2, right?

    Not sure why but generally LSCWP plugin won't change URL for that to https://www.buyatestkit.com/products/webfonts/fa-solid-900.woff2
    I suggest you log a ticket with us with your wordpress admin login and tmp root ssh access to your server for us to take a further look.
     
    Last edited by a moderator: Oct 1, 2018
  6. cabbola

    cabbola Member

    /wp-content/themes/storefront/assets/fonts/ is where the fonts are. The css is in /wp-content/themes/storefront/assets/ and that points to.. https://www.buyatestkit.com/wp-content/themes/storefront/assets/fonts/ Where would I send login information?
     
    Last edited by a moderator: Oct 1, 2018
  7. Pong

    Pong Well-Known Member Staff Member

    I can see fa-solid-900.woff2 is now on the same server ( maybe you change something, it was on remote server)
    https://www.buyatestkit.com/wp-content/themes/storefront/assets/fonts/fa-solid-900.woff2
    this is the correct location which supposed to be, right?

    I can see you are running cloudflare CDN and LiteSpeed at the backend server already.
    What's the steps to reproduce and see the error?
    You can send all such details and login info to support@litespeedtech.com
     
    Last edited by a moderator: Oct 1, 2018
  8. cabbola

    cabbola Member

    Hi there,
    fa-solid-900.woff2 was always at this URL https://www.buyatestkit.com/wp-content/themes/storefront/assets/fonts/fa-solid-900.woff2, however as soon as LiteSpeed Cache is enabled the URL in the CSS is different and that's why I get the error in the Google console.

    Something different is going on now, this is in addition to my first problem. When I enable LiteSpeed, it is enabled in green but I get this message on the LiteSpeed page,
    This issue is separate from my original problem. It must be a full moon or something.
    I have sent login details.
    Bob
     
    Last edited by a moderator: Oct 2, 2018
  9. cabbola

    cabbola Member

    I have fixed the last error by following your instructions to disable 'Include advanced-cache.php'
     
  10. cabbola

    cabbola Member

    LiteSpeed is now activated and the issue with fa-solid-900.woff2 is back
     
  11. Pong

    Pong Well-Known Member Staff Member

    As far as you log a ticket with all logged in details, we will take a further look there.
     

Share This Page